Install Google Chrome

Written by r2d2. Posted in Linux, Tips

Google Chrome isn’t in the repositories – however, Chromium is.

Google Chrome is only available for 64-bit Linux. I’ve included directions for 64 below.

To install Google Chrome, run the following:

sudo apt-get install libxss1 libappindicator1 libindicator7
wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
sudo dpkg -i google-chrome*.deb

If error messages pop up after running the command sudo dpkg -i google-chrome*.deb then run the command

sudo apt-get install -f

and then re-run the previous command. The error messages mentioned should include something similar to

google-chrome-stable depends on [lib-example]; however; Package [lib-example] is not installed.

This installs a needed library for Google Chrome, then downloads the latest version of Chrome to a temporary directory and installs it. Run google-chrome to start the browser.

During the installation a PPA is added to your system so that Google Chrome receives the latest updates whenever you check for system updates.

120 views

Unable to create symlink “/etc/pam.d/vmtoolsd” pointing to file “/usr/lib/vmware-tools/configurator/pam.d/vmtoolsd-x64”.

Written by r2d2. Posted in Linux

This Issue come from the Missing /etc/pam.d directory so to Solve is
Create it: mkdir /etc/pam.d


Before running VMware Tools for the first time, you need to configure it by
invoking the following command: “/usr/bin/vmware-config-tools.pl”. Do you want
this program to invoke the command for you now? [yes]

Unable to create symlink “/etc/pam.d/vmtoolsd” pointing to file
“/usr/lib/vmware-tools/configurator/pam.d/vmtoolsd-x64”.

Execution aborted.

152 views

gnome layout manager

Written by leif. Posted in Linux

https://github.com/bill-mavromatis/gnome-layout-manager

For the Windows 10 theme, also install this plugin:

https://extensions.gnome.org/extension/1160/dash-to-panel/

An icon taskbar for the Gnome Shell. This extension moves the dash into the gnome main panel so that the application launchers and system tray are combined into a single panel

 

128 views

Proxmox – add new disk – quickguide

Written by leif. Posted in Linux, Proxmox, Tips

cfdisk /dev/sda
mkfs.ext3 /dev/sda1
mkdir /disk2
blkid /dev/sda1

nano /etc/fstab
indsæt UUID=”97174799-0902-43b7-86d3-e42417xxxxxx” /disk2 ext3 errors=remount-ro 0 1
mount /disk2

Proxmox – log out and then back in
Datacenter/storage/add/Directory
id: Disk2
Directory: /disk2
Content: Diskimage/Container template

153 views

Network configuration

Written by leif. Posted in Linux, Netværk

Manual configuration with root credentials of the network config file, which is the responsible for the IP information in my debian system. The file name is /etc/network/interfaces I will first make backup of my original file as /etc/network/interfaces.bak and then proceed for the changes /etc/network/interfaces

mv /etc/network/interfaces /etc/network/interfaces.bak

sudo nano /etc/network/interfaces

I will change  the value like this

auto lo
iface lo inet loopback


#My IP description
# IPv4 address
iface eth0 inet static
	address	192.168.1.100
	netmask	255.255.255.0
	network	192.168.1.0
	broadcast 192.168.1.255
	gateway	192.168.1.1
496 views

ESXi 6.5 – Memory limit doesn’t accept the negative value -1048576

Written by leif. Posted in ESX, Linux, Tips

Memory limit doesn’t accept the negative value -1048576 error

MacOS Sierra 10.12 and Safari 10.0. Reopening the ‘edit’ screen produces a Memory limit doesn’t accept the negative value -1048576 error. This was also in the previous OS X and Safari error. Reloading the page (cmd + R) fixes it, then you can reopen the edit screen and make changes.

I use Firefox instead, it´s easier.

2027 views

Cool retro terminal

Written by leif. Posted in Linux, OS X

Install the App for OS X

  1. Press Command+Space and type Terminal and press enter/return key.
  2. Run in Terminal app:
    ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)" < /dev/null 2> /dev/null ; brew install caskroom/cask/brew-cask 2> /dev/null
    and press enter/return key. Wait for the command to finish.
  3. Run:
    brew cask install cool-retro-term

Done! You can now use cool-retro-term.

Checkout COOL THEMES FOR COOL RETRO TERM

Source macappstore.org

Install the App for Linux

To install cool-retro-term in Ubuntu based Linux distributions, such as Linux Mint, elementary OS, Linux Lite etc, use the PPA below:

sudo add-apt-repository ppa:noobslab/apps
sudo apt-get update
sudo apt-get install cool-retro-term

If you get the error: Error sudo: add-apt-repository: command not found

Install the add-apt-repository:

apt-get install software-properties-common

and repeat the installation.

226 views

Ubuntu: moving the Launcher to the bottom of the window

Written by leif. Posted in Linux, Tips

First install the dconf-editor.unitya

To do this, issue the command

  • sudo apt-get install dconf-editor
  • Open the program dconf-editor
  • Navigate to com / canonical / unity / launcher
  • and change the launcher-position to bottom.

 

or at the terminal type:

gsettings set com.canonical.Unity.Launcher launcher-position Bottom

Install compiz

sudo apt-get install compizconfig-settings-manager compiz-plugins compiz-plugins-extra

 

860 views

Things To Do After Installing Elementary OS Freya

Written by leif. Posted in Linux

Update your system

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

elementary Tweaks

sudo add-apt-repository ppa:mpstark/elementary-tweaks-daily
sudo apt-get update
sudo apt-get install elementary-tweaks

Install VLC Media Player

sudo apt-get install vlc

Install Plugin Flash Player and Pepper Flash

sudo apt-get install flashplugin-installer pepperflashplugin-nonfree

Install Additional Web Browser

sudo apt-get install chromium-browser firefox

Install Graphic Editor

sudo apt-get install gimp inkscape

 Install Indicator Synapse

sudo add-apt-repository ppa:elementary-os/daily
sudo apt-get update
sudo add-apt-repository ppa:elementary-os/unstable-upstream
sudo apt-get update
sudo apt-get install indicator-synapse
sudo killall wingpanel

Or

Install Synapse

sudo add-apt-repository ppa:synapse-core/ppa 
sudo apt-get update
sudo apt-get install synapse

Execute Synapse from the slingshot launcher

 

Install Cloud Storage

Download DropBox : https://www.dropbox.com/install?os=lnx

Install Google Drive :

sudo add-apt-repository ppa:alessandro-strada/ppa
sudo apt-get update
sudo apt-get install google-drive-ocamlfuse

 For Laptop : Install TLP for Improve Battery Life and Reduce Overheating

sudo add-apt-repository ppa:linrunner/tlp
sudo apt-get update
sudo apt-get install tlp tlp-rdw
sudo tlp start

Disktools:

sudo apt-get install gnome-disk-utility

2698 views